hyqd.net
当前位置:首页 >> linux下安装lAmp环境时安装ApAChE报错,错误如下 >>

linux下安装lAmp环境时安装ApAChE报错,错误如下

建议你make clean再试试.libtool: install: error: cannot install `libaprutil-1.la' to a directory not ending in /usr/local/apache2--sysconfdir=/etc/httpd/lib这个错误--sysconfdir=/etc/httpd/lib ..实际参数是/etc/httpd

建议你make clean再试试.libtool: install: error: cannot install `libaprutil-1.la' to a directory not ending in /usr/local/apache2--sysconfdir=/etc/httpd/lib这个错误--sysconfdir=/etc/httpd/lib ..实际参数是/etc/httpd

配置文件第87行出现的配置问题,检查一下看是不是敲错了字符.

此问题正解如下: 修改了apache服务的主配文件之后,启动apache启动不起来,报如楼主图一所示,是由于SElinux引起的 #解决办法: 编辑/etc/sysconfig/selinux #修改过后需要重启系统. 重启完毕之后可以解决.#如果还是不能解决使用命令 chcon -t texrel_shlib_t /usr/local/apache2/modules/libphp5.so (报错提示的文件路径) 修改过之后问题成功解决!!! 问题提了这么久了,也没有人回答,只好自己解决了之后自己来回答咯..

httpd.conf 文件有问题.Linux没有php.ini-dist文件,文件在源码目录,文件名是 php.ini-development 和 php.ini-production,一个是开发环境用另一个是生产环境用,拷贝一个就行.

新手不建议自己编译,yum install httpd 或者apt-get install httpd 如果非要编译的话从apache的官网下载合适的版本,按照官方文档进行操作.

也不知道你用的是什么linux系统但你这个问题是因为没有c编译器的问题.先给你两个版本redhat:yum search gcc 然后 yum install +(你要下的gcc的版本)ubuntu:sudo apt-get install gcc libc6-dev

他已经提示你了你缺少install-shinstall.sh你这里面少东西去下个新的源码包

看到你的报错是 iptables 防火墙的问题.应该和apache 没有关系.咱们慢慢说说吧.Linux下面的apache 最简单的方法就是用yum 来安装,服务的名称是httpd,yum仓库要可用.yum -y install httpd service httpd start \\启动httpd服务chkconfig httpd

启用modphp

相关文档
qhgj.net | zxsg.net | kcjf.net | skcj.net | ydzf.net | 网站首页 | 网站地图
All rights reserved Powered by www.hyqd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com